Canon 1900 и Ubuntu x64

Canon 1900 и Ubuntu x64

Установить принтер Canon Pixma IP1900 на Ubuntu 10.10 x32 у меня не составило труда, скачав с оф. сайта Canon пару .deb пакетов драйверов. Но я установил потом себе 64-битную ось и «дрова» как назло не хотели становиться, ругаясь на несовместимость архитектуры. Ну ясное дело — «дрова» для x32, а у меня система x64. Но принтер то ставить нужно, а на сайте Canon версии для x64 и в помине нет. Что делать? Ну ясный перец пошел «гуглить». Честно скажу, что огромного потока информации по этой проблеме я не нашел, но все же кое-какую выудил.

И заключалась она в том, что нужно было установить все те же самые драйвера, но принудительно. Одним словом через программу Midnight Commander, которая есть в репозиториях Ubuntu и вызывается командой MC в терминале, мы заходим в папку с драйверами, а они у меня имели такой вид — cnijfilter-common_3.00-1_i386.deb и cnijfilter-ip1900series_3.00-1_i386.deb и вводим поочередно 2 команды:

sudo dpkg -i —force-architecture cnijfilter-common_3.00-1_i386.deb
sudo dpkg -i —force-architecture cnijfilter-ip1900series_3.00-1_i386.deb

После ввода первой команды и нажатия клавиши ENTER, вас попросят ввести пароль. Киваете головой, вводите свой пароль и затем вводите вторую команду. Лично я сначала пишу нужные мне команды в текстовом редакторе Gedit, а потом просто копирую и вставляю в Midnight Commander, но это кому как нравится. Но самое главное, что после этого принтер без проблем опознался системой и работает до сих пор.